Consolidating Multiple Images to One Row (Excel Trick)

  • Unfortunately the data templates associated with each lab's version of FLOW are not the same and cannot be used interchangeably.

  • This Excel tip is useful for bringing images from another lab's FLOW software into the RPL FLOW software.

Step 1: Export Project Images (with Data)

  1. Export Images with Data by clicking on the Export button ( ) and select Export Project -> Images (with data)

  2. Or Export using an ImageMatch Export ImageMatch Export from FLOW and select All Images for the export. The ImageMatch exports the images and associated data file which will be used to build a new project.

Step 2: Edit the exported CSV file

Formulas:

  • C refers to column with Student ID, if Student ID or the Unique variable being referenced is not C, replace C in the formulas with that column letter

  • F refers to column with original image name, if the Image column being referenced is not F, replace F in the formulas with that column letter

  • e.g. if referencing is a different

Column HeadingFormula
Image 1=$F2
Image 2=IF($C2=$C3,$F3,"")
Image 3=IF($C2=$C4,$F4,"")
Image 4=IF($C2=$C5,$F5,"")

Sort your Data:

  1. Copy your data to a new spreadsheet so you can refer back to the original

  2. Click on cell with Unique Data (e.g. StudentID or Ticket Code) and click the Sort button found in the Data tab

  3. Check My Data Has Headers and select StudentIDfrom the dropdown list

Consolidate Images to One Row:

  1. Copy Formulas and column headings to the end of your spreadsheet ensure that you put an '=' before each

    1. e.g. =$F2 is added to column Image 1 (or H)

    2. For these formulas to work properly Student ID (or unique value) must be in Column C and the original images must be in Column F

  2. Highlight the cells beneath Image 1-4 and drag to the end of your spreadsheet. This will copy formula to each cell

      1. You should see that the first line of each unique value has at least Image 1 filled if not more

Convert Formulas to Data

  1. Shift + Click on newly created columns and data (columns with Image 1-4) and Copy (right-click copy or CTRL+C)

  2. With the same selection highlighted right-click -> Paste Special -> Values and click OK

Removing Duplicates:

  1. Click on cell A1

  2. Click on the Remove Duplicates button found in the Data tab

  3. Check My Data Has Headers and Unselect All

  4. Check columns First Name, Last Name and Student ID and click OK

  5. Your Data should now be consolidated, if it's not double-check the steps above